fonctions utilisées : gauche(), base( ; )

Premier chiffre d'un produit

le principe

On s'intéresse au premier chiffre du produit de deux entiers compris entre 1 et 99. Parmi les entiers compris entre 1 et 99, il y en a 11 qui commencent par 1, 11 qui commencent par 2, …

avec un tableur

On crée une table de multiplication Mais on veut seulement afficher le premier chiffre. On peut compter les 1, les 2 … avec des formules du genre =NB.SI($B$2:$CV$100;"1")
Attention

des résultats étonnants

On peut faire le bilan de la répartition.

On constate que les 1 sont les plus nombreux, puis les 2, les 3…

Maintenant nous multiplions tous ces 9801 résultats par 2. On obtient

On constate que les 1 sont encore plus nombreux…

On constate rapidement que quelque soit le nombre par lequel on multiplie, les 1 sont les plus nombreux, avec une fréquence qui varie à peu près, me semble-t-il entre 22% et 37% .

changeons de base

Si on exprime les nombres en base 7, par exemple, on constate que les 1 sont toujours les mieux représentés.
Ci-dessus une capture d'écran pour la base 4; on voit bien que les 1, en jaune sont les plus représentés.